LX Forums Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
217 Posts
Discussion Starter · #1 ·
So I just did this 5.7 to 6.1 swap and I used the fcm, ecu and tcm as well as the engine harness. Everything worked fine but I'm stuck on limp mode. Unfortunately we sold the 5.7 ecu. What do you guys recommend? I also have the donor cluster but have not installed it yet. Do you think any of the other modules will need to be changed? Thanks for your help in advance.
 

·
Registered
Joined
·
217 Posts
Discussion Starter · #3 ·
Thanks. We swapped the whole rear cradle as well. I use the appcar-diagfca to check all the information on the ecu and it still shows 2.82. Something somewhere is miscommunicating.
 

·
stay modded, my friend...
Joined
·
1,577 Posts
Congrats on getting it going, but why did the cluster have to be changed?
I am preparing to put an 6.1in my ‘07 MRT.
07 does not have FCM if that makes any difference. I have a 2007 MSRT PCM on hand and plan to rewrite VIN with AlphaOBD. Any reason I would need a cluster or anything else?
 

·
Registered
Joined
·
20 Posts
Congrats on getting it going, but why did the cluster have to be changed?
I am preparing to put an 6.1in my ‘07 MRT.
07 does not have FCM if that makes any difference. I have a 2007 MSRT PCM on hand and plan to rewrite VIN with AlphaOBD. Any reason I would need a cluster or anything else?
'07's are '07 only cars. They have a unique charging system and ignition system. The easy way out is using an '07 setup. Otherwise, starting & charging will be an issue. There may be other issues too but those I know of for sure. The 5.7 harness should work on the 6.1 as well as the PCM but an SRT8 PCM needs to be a 2007.
 
1 - 7 of 7 Posts
Top