LX Forums Forum banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
3,208 Posts
Discussion Starter · #1 ·
Our Kooks long tube header sale is still going but it looks like it will have to wrap up soon. You will need to give us a call receive a sale quote. This way prices don't get passed around the net like trading cards :) Some companies say they have good prices... but we really do! The quote you receive will include FREE shipping in the 48 states and orders are processed as they come in. Group purchase prices without the group purchase!

Orders can be placed online or by calling 1-877-482-9763.

Have a good day!
 

·
Premium Member
Joined
·
2,141 Posts
Tom,

I purchased a set of your coated Kooks long tube headers and high flow CATs for my Magnumb SRT8 a few months ago and have had CEL problem with rear 02 CAT sensor errors ever since the install. There are others on this forum who are also experiencing this problem with the Kooks......do you know of a fix?

One other thing, the 02 extension harness Kooks sends with their headers doesn't fit the Magnum 02 connector properly....you have to file down a tab to fit it in. I am not impressed so far with this purchase. Any ideas?

I have also sent off a note to George over at Kooks.
 

·
Premium Member
Joined
·
3,208 Posts
Discussion Starter · #3 ·
I see CELs with these headers on my own SRT-8. I've been waiting for a fix for this. I've been told that spacers for the rear 02s would take care of it. That would draw them out of the pipes a little.

Fitment for the extensions is tight. I'll see if there will be anything else to help them fit easier.
 

·
Premium Member
Joined
·
2,141 Posts
Hey thanks for the reply on the weekend Tom. I will try to find spacers for the rear 02 sensors tomorrow.

I had my Dodge dealer install the headers and they said the Kooks 02 sensor extension cable connector had to have a tab removed to fit into the Magnum connector so Kooks needs to know their connector isn't right.

Glen
 

·
Premium Member
Joined
·
3,208 Posts
Discussion Starter · #5 ·
Your very welcome Glen! I know the fitment is tight where that comes up. I'll have to take a look under a car during the next install or just put mine up on the lift to see how they are. I know that I didn't have to do any trimming. Maybe it's just something with the Magnum.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top