LX Forums Forum banner
21 - 31 of 31 Posts

·
stay modded, my friend...
Joined
·
1,577 Posts
At least your chase has come to an end and you can get this car going!
 
  • Like
Reactions: Hemihackman

·
Praise the Lowered!
Joined
·
1,230 Posts
Discussion Starter · #24 ·
Got everything in, smoothly I might add. I got a whole block before something made a noise, stalled the car and lost all gears but park.

Tomorrow morning it’s being towed to a shop. I’m not pulling this out again.

Here it sits.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
123 Posts
Didn't you have the thread with the spacer plate issues? And said you left the tc on the engine the first time and used the bolts to pull the engine and trans together?

Sent from my SM-G988U using Tapatalk
 

·
stay modded, my friend...
Joined
·
1,577 Posts
Got everything in, smoothly I might add. I got a whole block before something made a noise, stalled the car and lost all gears but park.

Tomorrow morning it’s being towed to a shop. I’m not pulling this out again.

Here it sits.




Sent from my iPhone using Tapatalk
Sorry to hear. What a frustration. Car looks awesome at least!
 

·
Praise the Lowered!
Joined
·
1,230 Posts
Discussion Starter · #27 ·
Didn't you have the thread with the spacer plate issues? And said you left the tc on the engine the first time and used the bolts to pull the engine and trans together?

Sent from my SM-G988U using Tapatalk
No, my spacer plate is in there. I did have problems a few months ago, and I'm convinced I did all the damage myself. I'm to blame.
 

·
Praise the Lowered!
Joined
·
1,230 Posts
Discussion Starter · #30 ·
Ah, okay. I remember someone having issue. Plate was on backwards, I think even wrong starter.

Sent from my SM-G988U using Tapatalk
That was me- but I didn't install the motor with the TC already on, it was in the trans.

Shop still has the car- I got a call yesterday that I obliterated my pump and I'm waiting for further diagnostics.
 

·
Praise the Lowered!
Joined
·
1,230 Posts
Discussion Starter · #31 · (Edited)
Update

So it turns out I ate the pump, the TC housing, TC itself, stator splines and destroyed the pump (again)

I found a used trans out of a Charger for $150 at the local wreckers. Perfect for replacement parts. I’ve got the shop taking ALL my transmission parts (including the internals from my AWD NAG1) and building me a good solid trans out of three. So I’m the end I have a brand new 0 mile motor and a strong transmission. I’m going with the 3.5L torque converter (again) cause it has a higher stall than the stock R/T one and I installed a COMP Cam.

First two pics are getting the trans from the wreckers. The other pics are of my damaged parts.

Again, this was all from my install that I really messed up somehow.

















Sent from my iPhone using Tapatalk
 
21 - 31 of 31 Posts
Top