LX Forums Forum banner
101 - 115 of 115 Posts

·
Registered
Joined
·
2 Posts
Hi guys, I have a 2005 Magnum R/T and the blowermotor stopped to work and the airbag light is on (the light comes on when you "turn on" the blower and disapears when you shut it down)
This far I have tried toi change the blower motor and the resistor (didn´t help)
I have 12V to the blower motor but it doesn´t work, any ideas what it could be?

Thankful for Help =)
//Tommi
No one got any ideas?
 

·
Registered
Joined
·
5 Posts
My wife was driving our 2006 chrysler 300c srt8 and hit a pothole and after rhat the air bag light came on in the cluster and now the climate control wont work. Acts like it has no power going to it. Checked all fuses and the two diodes and they r all good. Do u know what the problem may be? Also do u. Have a diagram of the climate control wiring,the air bag wiring diagram and the ignition switch wiring diagram?
 

·
Life is pretty good
Joined
·
6,251 Posts
My wife was driving our 2006 chrysler 300c srt8 and hit a pothole and after rhat the air bag light came on in the cluster and now the climate control wont work. Acts like it has no power going to it. Checked all fuses and the two diodes and they r all good. Do u know what the problem may be? Also do u. Have a diagram of the climate control wiring,the air bag wiring diagram and the ignition switch wiring diagram?
For all wiring diagrams, check the knowledge base for the complete service manual. Have you checked the connection at the back of the HVAC unit?
 

·
What'd I miss?
Joined
·
23,442 Posts
My wife was driving our 2006 chrysler 300c srt8 and hit a pothole and after rhat the air bag light came on in the cluster and now the climate control wont work. Acts like it has no power going to it. Checked all fuses and the two diodes and they r all good. Do u know what the problem may be? Also do u. Have a diagram of the climate control wiring,the air bag wiring diagram and the ignition switch wiring diagram?
assuming you have ATC (auto temp control/4 knobs).
what, exactly doesn't work on the climate control (fan/modes/temp/completely unresponsive)?
 

·
Banned
Joined
·
1,575 Posts
Same problem...I'm not getting power at green pink with key on fnky. What's your thoughts?
 

·
Banned
Joined
·
1,575 Posts
I only have diode 1 also no number 2 diode
 

·
Banned
Joined
·
1,575 Posts
Well i moved diode number 1 into number 2 spot now it works....no idea how diode number two disapired i haven't opened that fuse box in month's and it stopped working after i came home turned off the car and re started it..i never left the vehicle so nobody opened the trunk and took it...I'm so lost lol..Hudini diode
 

·
Registered
Joined
·
42 Posts
Ok guys hopefully fnkychkn is still around but I have a 2008 dodge charger rt daytona package but driving home today the air bag light in the dash came on and lost all communication with the ac controls(dual).
OK so I swapped the diode into the number 2 spot and I got my ac to work and my airbag light to go off.
But when I did that I got my traction control lights on and the little red light in the fuel gauge started blinking as if the alarm(factory) was armed. I didn't have tools on me but by looking at the fuses they seem ok going to test them tomorrow. All and any help appreciated


Sent from my SAMSUNG-SM-G870A using Tapatalk
 

·
What'd I miss?
Joined
·
23,442 Posts
Ok guys hopefully fnkychkn is still around but I have a 2008 dodge charger rt daytona package but driving home today the air bag light in the dash came on and lost all communication with the ac controls(dual).
OK so I swapped the diode into the number 2 spot and I got my ac to work and my airbag light to go off.
But when I did that I got my traction control lights on and the little red light in the fuel gauge started blinking as if the alarm(factory) was armed. I didn't have tools on me but by looking at the fuses they seem ok going to test them tomorrow. All and any help appreciated

Sent from my SAMSUNG-SM-G870A using Tapatalk
When you say you "swapped the diode into the number 2 spot", where did you get the diode from?
 

·
Registered
Joined
·
42 Posts
When you say you "swapped the diode into the number 2 spot", where did you get the diode from?
I swapped from number 1 slot to number 2 slot I didn't have a number 2 diode at all or at least to my knowledge no audio systems or anything like that and this the first time I've ever messed with the fuse box

That's the red light that blinks when I move diode from slot 1 into slot 2
Sent from my SAMSUNG-SM-G870A using Tapatalk
 

·
Registered
Joined
·
1 Posts
I've seen many posts and videos on (Air Bag On/Cluster not working).
Most say replace everything in Rear Power Distribution Center.

I did that with no luck.

I saw a video saying move diode D1 to D2 position, and that solved (Air Bag On/Cluster nor working)
but D1 controls Transmission and I received error codes and Transmission would only do "limp" mode.

Moved D1 back and bought $3 diode for D2.

Waiting to receive new diode but I'm certain that I'm back in business again.
 
101 - 115 of 115 Posts
Top