LX Forums Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. 300 General Discussion (1st Gen - 2005 to 2010)
    I'm at wits end and really need some help here. 2005 300C 5.7 89,000 miles Ran fine and then one day would crank but not start. Wouldn't even catch. Starts briefly on starting fluid and dies immediately. NO Codes. After a bunch of new parts it starts with Starting Fluid but runs like it was...
  2. 300C, Magnum RT & Charger RT (5.7L V8)
    I have a 2007 Dodge Charger R/T Recently, the car was turning off but it would restart right away. The check engine light will come on, so I replaced 2 sensors (crankshaft position sensor and oil pressure sensor) based on those codes. Then the alternator went bad so I replaced that too. Car...
  3. Charger Discussion (1st Gen - 2006 to 2010)
    I have a 07 charger v6, kid ran it out of gas and after we got fuel in it it still took awhile to start. Ran ok for a week or 2 and yesterday would turn over but fuel pump was not coming on. They tried to continue to start the car. Now when you turn the key to start nothing happens. Check...
  4. Newbie Check-In
    really nice site i got a 05 Magnum
  5. 300C, Magnum RT & Charger RT (5.7L V8)
    I have an 05' Magnum RT. Had some issues with error codes. Replaced PCM and had TC 02305. This inturn burned up my #2 ignition coil. Replaced the coil and installed another reflashed PCM. The car will turn over but won't start. I need some help with this problem.
1-5 of 5 Results
Top