Results 1 to 15 of 15
  1. #1
    Join Date
    Jul 2017
    Location
    Riverside Ca
    Posts
    154
    Post Thanks / Like

    Navigation UConnect

    Looking to buy a UConnect with Navigation for my 2016 Dodge Charger. Mines didn’t come with one. Does anyone know if i need accessories to make it work or is just plug and play ?


    Sent from my iPhone using Scat Pack Forums



  2. #2
    Join Date
    Nov 2015
    Location
    Eastern NC
    Posts
    804
    Post Thanks / Like
    I believe you will need a Tazer to allow the swap if you get one from the junkyard. There is a company that sells a plug and play Uconnect that will give you all the current features of the latest Uconnect units as well, but it is like $1K+.

    Hopefully someone with experience swapping units will chime in on the junkyard swap option.
    '18 Charger SP - Tech/Driver's/Beats Packages, WRT wheels - Tazer
    Previous:
    '17 Camaro 2SS A8

  3. #3
    Join Date
    Jul 2018
    Posts
    20
    Post Thanks / Like
    This link may or may not help if you have the right code on your build sheet. Found this a few years ago +/-.

    https://www.dealers-mopar.com/downlo...guide-1231.pdf
    Last edited by Donf; 01-14-2021 at 02:09 PM.
    2020 Hellraisin Charger Scat Pack Widebody

  4. #4
    Join Date
    Jul 2017
    Location
    Riverside Ca
    Posts
    154
    Post Thanks / Like
    Quote Originally Posted by SuperSound View Post
    I believe you will need a Tazer to allow the swap if you get one from the junkyard. There is a company that sells a plug and play Uconnect that will give you all the current features of the latest Uconnect units as well, but it is like $1K+.

    Hopefully someone with experience swapping units will chime in on the junkyard swap option.
    Ok got it. Thanks for that info.


    Sent from my iPhone using Scat Pack Forums

  5. #5
    Join Date
    Jun 2019
    Location
    SoCal
    Posts
    57
    Post Thanks / Like
    The 8.4 Uconnect Unit is a direct plug in swap from the 5" unit by itself. From my experience swapping units, as long as you have the shark fin antenna factory, it wont have any problems. The ones I've seen having sms connection errors are the base models without the antenna.
    The Uconnect automatically calibrates itself off the BCM after a few ignition cycles and/or battery disconnect. (Ive tried charger in a challenger before and viceversa)
    I have a 2016 unit for sale as I swapped my 2016 challenger 8.4 with a 2020 challenger uconnect (also works without any issue or reprogramming) I'll probably get around to post it up in the FS section later, or you can DM me if interested

    The ONLY unit I've had an issue with is putting a 2019 300 8.4 in my 2016. 2020 was no issue.

  6. #6
    Join Date
    Nov 2015
    Location
    Eastern NC
    Posts
    804
    Post Thanks / Like
    Quote Originally Posted by AllenSunnyD View Post
    The 8.4 Uconnect Unit is a direct plug in swap from the 5" unit by itself. From my experience swapping units, as long as you have the shark fin antenna factory, it wont have any problems. The ones I've seen having sms connection errors are the base models without the antenna.
    The Uconnect automatically calibrates itself off the BCM after a few ignition cycles and/or battery disconnect. (Ive tried charger in a challenger before and viceversa)
    I have a 2016 unit for sale as I swapped my 2016 challenger 8.4 with a 2020 challenger uconnect (also works without any issue or reprogramming) I'll probably get around to post it up in the FS section later, or you can DM me if interested

    The ONLY unit I've had an issue with is putting a 2019 300 8.4 in my 2016. 2020 was no issue.
    Bare in mind the OP has a 8.4, he just doesn't have NAV. That's not plug in play from what I've read, since the display in the center needs to be coded to display NAV. Think that's why I read tazer was needed.

    Sent from my SM-G975U1 using Tapatalk

  7. #7
    Join Date
    Feb 2018
    Location
    Boca Raton, fl
    Posts
    591
    Post Thanks / Like
    2013 Chrysler 300 had RE2 no nav. Bought a RB5 installed, plug and play. I had to get the unlock code from dealer, you need receipt and donor vin.

    Got very lucky I think, mine came from a 2013 Chrysler 300.. some say there are other steps if it came from another model.

    Screen doesn't need to be changed, just head unit behind control panel. Best to check model of radio first, could be nav ready, just not turned on.
    Last edited by coanan; 01-14-2021 at 09:19 PM.
    13 Chrysler 300S, Stock 17 RAM 6.4 BGE with TSP Stage 4 boosted Cam, AIT 18% OD pulley, E-force 2.62 pulley(12.2 lbs boost),, Fastman 84+4 mm throttle body, 1 7/8 kooks long tubes w/hi-flow cats, 3" Magnaflow Cat-back, FTI 2800 stall, Trans by Hellraiser, Dings Racing valve body and tune, Getrag 3.73, Walbro 400LPH, DW 65# inj. aluminum rad. SRT fans. Brembo upgrade. Stage one MOPAR springs, XIX X39 22x9 +15 - 22x10.5 +22 with NITTO NT555 265/35R22 - 295/30R22

  8. #8
    Join Date
    Mar 2016
    Location
    N. GA
    Posts
    600
    Post Thanks / Like
    I have a 2013 R/T was non-nav. Purchased used nav unit from 20145 300 from Veldmans Auto Parts for $225.00. Called dealer with donor vin and got the pin.
    Its been fine for months.
    First startup it was Chysler Blue, next start it was Dodge Red.
    2013 Dodge Charger R/T Plus, Edelbrock E-Force 2300TVS 6.4 PSI, Mustang-Dyno Tuned 418hp/430tq, 3.06:1, Severe Duty Radiator, Dual Fans, OE Oil Cooler, Pursuit BR9 Brakes, Corsa CatBack, Bilstein Dampers, Catch Can, AlfaOBD enabled Sport Mode & SRT Pages, Fogs on w/High Beams, Add Reverse Cam & Auto Dimming & Tilt in Reverse Left Door Mirror.



  9. #9
    Join Date
    Jul 2017
    Location
    Riverside Ca
    Posts
    154
    Post Thanks / Like
    Quote Originally Posted by AllenSunnyD View Post
    The 8.4 Uconnect Unit is a direct plug in swap from the 5" unit by itself. From my experience swapping units, as long as you have the shark fin antenna factory, it wont have any problems. The ones I've seen having sms connection errors are the base models without the antenna.
    The Uconnect automatically calibrates itself off the BCM after a few ignition cycles and/or battery disconnect. (Ive tried charger in a challenger before and viceversa)
    I have a 2016 unit for sale as I swapped my 2016 challenger 8.4 with a 2020 challenger uconnect (also works without any issue or reprogramming) I'll probably get around to post it up in the FS section later, or you can DM me if interested

    The ONLY unit I've had an issue with is putting a 2019 300 8.4 in my 2016. 2020 was no issue.
    Yes i have the shark fin antenna and your telling me it’s a plug and go without complications?


    Sent from my iPhone using Scat Pack Forums

  10. #10
    Join Date
    Jun 2019
    Location
    SoCal
    Posts
    57
    Post Thanks / Like
    Quote Originally Posted by LouMarq View Post
    Yes i have the shark fin antenna and your telling me it’s a plug and go without complications?


    Sent from my iPhone using Scat Pack Forums
    Never had a problem with the same year radio swap. And this one does have NAV
    I'm in Chino, so if you're up to testing out the radio we can plan something out. I have the unlock code aswell.

  11. #11
    Join Date
    Jul 2017
    Location
    Riverside Ca
    Posts
    154
    Post Thanks / Like
    Quote Originally Posted by AllenSunnyD View Post
    Never had a problem with the same year radio swap. And this one does have NAV
    I'm in Chino, so if you're up to testing out the radio we can plan something out. I have the unlock code aswell.
    Got and update. The console it’s from a 2018 Charger. Will that cause a problem?


    Sent from my iPhone using Scat Pack Forums

  12. #12
    Join Date
    Nov 2015
    Location
    Eastern NC
    Posts
    804
    Post Thanks / Like
    Think you should be good. A 2018 will give you Android Auto/Carplay as well. Not sure if the USB hub needs to be swapped (something about different USB pins needed).

    Sent from my SM-G975U1 using Tapatalk

  13. #13
    Join Date
    Jun 2019
    Location
    SoCal
    Posts
    57
    Post Thanks / Like
    Quote Originally Posted by SuperSound View Post
    Think you should be good. A 2018 will give you Android Auto/Carplay as well. Not sure if the USB hub needs to be swapped (something about different USB pins needed).

    Sent from my SM-G975U1 using Tapatalk
    Yes the usb hub needs to be swapped for the one with the two usb ports and no card reader. The uconnect functions fine with the old one still installed, but will give you a 'usb hub not supported' message. And it won't work.

    Sent from my SM-G955U using Tapatalk
    Likes SuperSound liked this post

  14. #14
    Join Date
    Jul 2017
    Location
    Riverside Ca
    Posts
    154
    Post Thanks / Like
    Here is the current radio i have.

    IMG_5323.JPG


    Sent from my iPhone using Scat Pack Forums

  15. #15
    Join Date
    Oct 2016
    Location
    Toledo, OH
    Posts
    486
    Post Thanks / Like
    No need to buy or install any hardware really. On the '15s and '16s you can just pay an absurdly high fee ($595) and unlock nav on the existing radio if that's all you want-
    Uconnect 8.4A (RA3) Activation | HERE
    '17 Destroyer Gray Charger Daytona 392

Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •