Page 2 of 6 FirstFirst 1234 ... LastLast
Results 16 to 30 of 86

Thread: Pads vibrating?

  1. #16
    Join Date
    Jun 2016
    Location
    Georgetown, Tx
    Posts
    1,597
    Post Thanks / Like
    I’ve had no issues with my braking performance nor has the brake pedal ever felt weird. It really doesn’t concern me. Just something I’ve noticed.


    2016 Charger Scat Pack
    LMI Intake
    3.70 gears
    Borla Atak
    Active exhaust delete
    Hemifever Tuning
    2016 Charger Scat PackLMI Intake3.70 gearsLongtube headersBorla AtakActive exhaust deleteHemifever Tuning
    Likes Heat00 liked this post



  2. #17
    Join Date
    Dec 2016
    Location
    Ft. Lauderdale, FL
    Posts
    2,913
    Post Thanks / Like
    I hear ya... at least I've eliminated the dust issue LOL... it's out of control with the stock pads...Also, I think the stock pads are semi metalic and eat up those rotors, which aren't cheap....
    '19 Scat Pack F8 Green; '18 Audi SQ5 Daytona Grey '18 Daytona 392; 16 Scat Pack Granite; '15 Durango R/T Blacktop '14 Volvo S60R Rebel Blue; '12 Audi Q5; '10 Mustang; '08 E90 M3; '07 335I Active Autowerks ...

  3. #18
    Join Date
    Mar 2018
    Posts
    187
    Post Thanks / Like
    Quote Originally Posted by Heat00 View Post
    Sounds like only you and I have the exact same problem , others are similar but not the same.
    I notice the same exact problem and mine would go away also after a stop which means they cooled down. They did stop fine but like you, the pedal felt aweful and scary... if they work fine but don’t feel good I’m not to worried about it.
    I can’t comment now as I’ve only had them on my new scat for one day but I’m hoping not to have this problem this time.

    Perhaps the bed in process wasn’t done right? How many miles did you have on the rotors when the powerstops went on?

    My first scat didn’t have the issue but they were the Z23’s not that it should matter but more importantly, the rotors were already warped and I installed the powerstops with brand new oem rotors and never had an issue. They were also the 4 piston.

    Next is the Daytona and I think I had 5/6000 miles when I installed the powerstops. Had the wet issue bad, so maybe the rotors were already worn down some from the stock pads which eat up rotors btw....

    I don’t know just trying to look at all the variables. This scat has 1900 miles so we’ll see how they act... I’m sure it’ll rain soon lol...




    Sent from my iPhone using Scat Pack Forums
    The only thing I can think of is it might be a slight difference between the z23 and z26 pads. My scat had about 1,100 miles on it when I put my z23's on. I've never felt a wierd vibration. But it could be because the z26's have SST backing pads on them and the z23's are rubber. The rubber could diffuse any vibration caused in this instance. Just my 2 cents. Seems like most people that have had vibration issues with powerstops have all had z26's.

    Sent from my SM-G950U using Tapatalk
    Likes inssane, Heat00 liked this post

  4. #19
    Join Date
    Dec 2016
    Location
    Ft. Lauderdale, FL
    Posts
    2,913
    Post Thanks / Like
    Quote Originally Posted by aaron.moore39 View Post
    The only thing I can think of is it might be a slight difference between the z23 and z26 pads. My scat had about 1,100 miles on it when I put my z23's on. I've never felt a wierd vibration. But it could be because the z26's have SST backing pads on them and the z23's are rubber. The rubber could diffuse any vibration caused in this instance. Just my 2 cents. Seems like most people that have had vibration issues with powerstops have all had z26's.Sent from my SM-G950U using Tapatalk
    hmmm... that's very interesting and actually a very plausible cause.... in any case, so far there are only 2 of us that i know of, that have this exact issue so it's very limited right now.I probably should have just gotten the z23's this time LOL..... you're a day late Aaron haha.... I thought the 26's would be better as they claim the SS helps dissipate heat better and therefore I thought they would be less likely to overheat or have these issues...I really don't know if we will ever pinpoint the issue.... If I don't have the problem with this new scat then it will help as we'll know its not the 26's and something else wrong before.the only other things I can think of I mentioned already: 1. perhaps the rotors were worn down a little before the powerstops were installed? or2. perhaps after the bed in process I got home and put the e-brake on (which some here say activates the pistons/pads so if hot that could imprint the rotors)? I guess 3. would be z26's vs z23's?is there anything else it could be? If you had the issue, you would know why it is driving us crazy... it's like hitting the brake pedal and although it stops fine, it feels like mush or like the rotors are warped beyond belief... it's really a frightening type feelingfor me it ONLY happened on long drives and rain combined.... that makes me thing it could be related to heat.... but who knows, I'm no mechanic or scientist LOL

  5. #20
    Join Date
    Dec 2016
    Location
    Ft. Lauderdale, FL
    Posts
    2,913
    Post Thanks / Like
    and sorry for the jumbled text...anyone know why It won't separate lines because when I type it leaves space between paragraphs but then it's all jammed up ... sorry

  6. #21
    Join Date
    Mar 2018
    Posts
    187
    Post Thanks / Like
    Quote Originally Posted by Heat00 View Post
    hmmm... that's very interesting and actually a very plausible cause.... in any case, so far there are only 2 of us that i know of, that have this exact issue so it's very limited right now.I probably should have just gotten the z23's this time LOL..... you're a day late Aaron haha.... I thought the 26's would be better as they claim the SS helps dissipate heat better and therefore I thought they would be less likely to overheat or have these issues...I really don't know if we will ever pinpoint the issue.... If I don't have the problem with this new scat then it will help as we'll know its not the 26's and something else wrong before.the only other things I can think of I mentioned already: 1. perhaps the rotors were worn down a little before the powerstops were installed? or2. perhaps after the bed in process I got home and put the e-brake on (which some here say activates the pistons/pads so if hot that could imprint the rotors)? I guess 3. would be z26's vs z23's?is there anything else it could be? If you had the issue, you would know why it is driving us crazy... it's like hitting the brake pedal and although it stops fine, it feels like mush or like the rotors are warped beyond belief... it's really a frightening type feelingfor me it ONLY happened on long drives and rain combined.... that makes me thing it could be related to heat.... but who knows, I'm no mechanic or scientist LOL
    Haha, that's funny sh**. The only other thing I could really think of is the other options you stated. I know It would make me sh** myself under something like that. Then of course, there are those of us who can tell when anything has changed or doesn't feel right/normal with our cars. I know if this was happening with my car I would tell right away, as where my wife wouldn't be able to tell anything until her wheel fell off. And maybe not even then, lol. Either way, I think you will be pleased with the z23's you got for your new scat. How are you liking the '19 anyways. You can get the multimode dampers and track mode on them correct?

    Sent from my SM-G950U using Tapatalk

  7. #22
    Join Date
    Dec 2016
    Location
    Ft. Lauderdale, FL
    Posts
    2,913
    Post Thanks / Like
    Quote Originally Posted by aaron.moore39 View Post
    Haha, that's funny sh**. The only other thing I could really think of is the other options you stated. I know It would make me sh** myself under something like that. Then of course, there are those of us who can tell when anything has changed or doesn't feel right/normal with our cars. I know if this was happening with my car I would tell right away, as where my wife wouldn't be able to tell anything until her wheel fell off. And maybe not even then, lol. Either way, I think you will be pleased with the z23's you got for your new scat. How are you liking the '19 anyways. You can get the multimode dampers and track mode on them correct?Sent from my SM-G950U using Tapatalk
    yea who knows... I did get the 26's though, hopefully that's not the problem lol.The 19 is great. Exhaust (note/tone) is different and better, deeper. an improvement. The grille has grown on me. It's my 3rd charger 392 lol. really mostly the same. It seems faster by a lot according to my 0-60 times. not sure why. more speculation maybe, but my 16 scat and my 18 daytona ran 4.5-4.6 every single time over 2 years. first run in the 19 it ran a 4.2. again who knows why lol. also getting 15.5 MPG, my last 2 got 17. Not sure about multimode dampers, I didn't get that option I guess... this one is pretty basic, only has red calipers, dynamics, and carbon black stripes. interior materials is not as nice, although I like the houndstooth design, the material without the daytona or alcantara package is not as good but I really don't care nor will I keep the car long enough for it to be a problem. Love the f8 with black stripes, love the dynamic package wheels, yes it has all the SRT performance pages now without needing tazer so track mode eco mode valet mode all built in!! Otherwise it's the same bad a** charger as the others... I just cannot get sick of the 392 sound, feel, performance, everything... just amazing cars for 40k and 4 doors!!!! I've already posted way too many pics lol but maybe ill dig up one more lol.....

  8. #23
    Join Date
    Dec 2016
    Location
    Ft. Lauderdale, FL
    Posts
    2,913
    Post Thanks / Like
    Looks different in the sun




    Sent from my iPhone using Tapatalk

  9. #24
    Join Date
    Mar 2018
    Posts
    187
    Post Thanks / Like
    Quote Originally Posted by Heat00 View Post
    Looks different in the sun




    Sent from my iPhone using Tapatalk
    Beautiful car. I love the f8 green. Such a deep unique color. The grill is definitely growing in me everytime I see someone real world pics of it. Kinda wierd about the 0-60 times. I live at about 5k ft above sea level. I could never get below 5.0. But after my motor blew up and got replaced I am now hitting 4.5-4.6 consistently without trying. Toasted a chevy ss the other day. I had massive wheel spin for about 50-60 ft. And I still hit 4.6. Must have just had a crap motor. But I love the color on yours. Sorry OP for changing the subject.

    Sent from my SM-G950U using Tapatalk

  10. #25
    Join Date
    Dec 2016
    Location
    Ft. Lauderdale, FL
    Posts
    2,913
    Post Thanks / Like
    thank you and yes I fell in love with the f8 and black stripes as soon as I saw it in person...can't believe you blew up a motor? LOL..... I need to drive more like you haha sounds like you have more fun than methe 0 -60 could just have been perfect conditions, new tires, and finally have learned after owning 3 of these, how to launch ? who knows... but I was thrilled when I saw the 4.2 as I fought hard in my first scat and my daytona and could never, not once, get below 4.5-4.6 and the 4.5 was only one time with new tires lol.....I bet I could get lower if I ran on a cooler day, but I'm in south florida and we don't get too many of those LOL

  11. #26
    Join Date
    Mar 2018
    Posts
    187
    Post Thanks / Like
    Quote Originally Posted by Heat00 View Post
    thank you and yes I fell in love with the f8 and black stripes as soon as I saw it in person...can't believe you blew up a motor? LOL..... I need to drive more like you haha sounds like you have more fun than methe 0 -60 could just have been perfect conditions, new tires, and finally have learned after owning 3 of these, how to launch ? who knows... but I was thrilled when I saw the 4.2 as I fought hard in my first scat and my daytona and could never, not once, get below 4.5-4.6 and the 4.5 was only one time with new tires lol.....I bet I could get lower if I ran on a cooler day, but I'm in south florida and we don't get too many of those LOL
    Lol, yeah it was quite surprising. Luckily wasnt anything I did that made it blow up. Had a major defect. There was something with the oil journal not allowing oil to get to cyl 3&4. The journal was super scorched. The bearings got hot and deteriorated slowly but surely. Bent 2 rods, shattered a piston. Blew a hole through into the oil pan. It's a 2018, only had 4,700 miles. Runs way stronger now. Especially after it's hot. The last motor just seemed like a dog after it got hot. There is a lot of sounds going on now with the body. Pops, creaks, ect. I guess FCA made them drop the front subframe to get the pics they wanted before they removed the motor. Car still has only 6,000 miles on it. But it sounds like a 10 year old car now. So it's kinda upsetting. I'm working with FCA to try to come up with some compensation. It's been frustrating to say the least. Needless to say, I still love my car. Just wish this hadn't have happened. Maybe they will throw me a 2019 Pads vibrating?

    Sent from my SM-G950U using Tapatalk

  12. #27
    Join Date
    Dec 2016
    Location
    Ft. Lauderdale, FL
    Posts
    2,913
    Post Thanks / Like
    Quote Originally Posted by aaron.moore39 View Post
    Lol, yeah it was quite surprising. Luckily wasnt anything I did that made it blow up. Had a major defect. There was something with the oil journal not allowing oil to get to cyl 3&4. The journal was super scorched. The bearings got hot and deteriorated slowly but surely. Bent 2 rods, shattered a piston. Blew a hole through into the oil pan. It's a 2018, only had 4,700 miles. Runs way stronger now. Especially after it's hot. The last motor just seemed like a dog after it got hot. There is a lot of sounds going on now with the body. Pops, creaks, ect. I guess FCA made them drop the front subframe to get the pics they wanted before they removed the motor. Car still has only 6,000 miles on it. But it sounds like a 10 year old car now. So it's kinda upsetting. I'm working with FCA to try to come up with some compensation. It's been frustrating to say the least. Needless to say, I still love my car. Just wish this hadn't have happened. Maybe they will throw me a 2019 Pads vibrating?Sent from my SM-G950U using Tapatalk
    wow, that's crazy... sorry to hear about the hassles... I guess every once a while a problem case arises, I'm glad you have a good attitude and don't hold it against the car lol.....I had one Durango RT and 3 charger 392's, mostly trouble free except for a few minor items on my daytona ...otherwise my durango went 70k and my first scat almost 40k with zero issues.they should definitely try to make you a nice deal into a new 19!!! that would be cool...so far Dodge/FCA has been quite ok to work with, they actually refunded me the extended warranty that I bought on my first scat, fairly quickly and without any arguments... which I found odd as usually these car people always promise refunds if those type things aren't used but never actually follow through... hopefully they make it right for you.. I would certainly keep the pressure on them as it's not right on such a new vehicle to have those kinds of issues...keep us posted on this one, very interesting to see how it ends

  13. #28
    Join Date
    Mar 2018
    Posts
    187
    Post Thanks / Like
    Quote Originally Posted by Heat00 View Post
    wow, that's crazy... sorry to hear about the hassles... I guess every once a while a problem case arises, I'm glad you have a good attitude and don't hold it against the car lol.....I had one Durango RT and 3 charger 392's, mostly trouble free except for a few minor items on my daytona ...otherwise my durango went 70k and my first scat almost 40k with zero issues.they should definitely try to make you a nice deal into a new 19!!! that would be cool...so far Dodge/FCA has been quite ok to work with, they actually refunded me the extended warranty that I bought on my first scat, fairly quickly and without any arguments... which I found odd as usually these car people always promise refunds if those type things aren't used but never actually follow through... hopefully they make it right for you.. I would certainly keep the pressure on them as it's not right on such a new vehicle to have those kinds of issues...keep us posted on this one, very interesting to see how it ends
    I will. I've tried to realize that with major production vehicles there is always some that will have issues. I bought this car because I researched the hell out of it. And they are generally very reliable for a high performance car. But I'll keep you posted where it goes. The dealership that fixed my car keeps telling me they will give me a fantastic deal on a 2018 hellcat they've had for about 8 months. I'm hoping I can find a way to get into that. Just depends on the deal. Fingers crossed.

    Sent from my SM-G950U using Tapatalk

  14. #29
    Join Date
    Jul 2017
    Posts
    199
    Post Thanks / Like
    Everything's been all good since the rain. I'm just surprised that I've driven in the rain funny before with it I never had this issue. when I change the wheels out I think I'm going to go in and check the backing plates and see if I need to apply any more grease to the metal as well. I suspect that it's the metal backing plates that could be the cause of the vibration. Why exactly it's happening and where the water is seemingly entering and causing the vibration I don't think I'll be able to tell.

    Sent from my Pixel 2 XL using Tapatalk
    Likes aaron.moore39, Heat00 liked this post

  15. #30
    Join Date
    Dec 2016
    Location
    Ft. Lauderdale, FL
    Posts
    2,913
    Post Thanks / Like
    Quote Originally Posted by aaron.moore39 View Post
    I will. I've tried to realize that with major production vehicles there is always some that will have issues. I bought this car because I researched the hell out of it. And they are generally very reliable for a high performance car. But I'll keep you posted where it goes. The dealership that fixed my car keeps telling me they will give me a fantastic deal on a 2018 hellcat they've had for about 8 months. I'm hoping I can find a way to get into that. Just depends on the deal. Fingers crossed.Sent from my SM-G950U using Tapatalk
    when I bought my 19 scat, they had a 18 HC billet grey that was beautiful... when I inquired with my guy, he said they ain't going below $68k period. That was only a few weeks ago.Man... I want a cat bad!!! but I'm with you, the difference in price doesn't seem to justify the difference in performance (MY OPINION ONLY). yes I realize its faster but 40k vs 68k for same car but faster is just so tough... it was closer to 60k i'd do it but not at 68k remember it's plus tax plus plus plus so it'll be over 70k.... and that was an 18 from the cheapest dealer in sofla....

Page 2 of 6 FirstFirst 1234 ... LastLast

Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •