Results 1 to 7 of 7
  1. #1
    Join Date
    Apr 2015
    Posts
    1
    Post Thanks / Like

    Help! 2014 Dodge Charger won’t start.

    Wednesday drove my car work with no issues. Got off went to start my car. Push the start button and no start, no crank. Dash, lights, radio all come on. Tried jumping it...nothing. Not even a crank. So ending up getting towed to my house. Tow truck even tried jumping and nothin. Took the battery to auto zone to be tested...Check out good. Checked all the fuses and relays...Good. Took of the starter and got it tested at o Reilly’s...Passed. Already had alternator replaced bc of recall a while back. Any one gone through the same thing or have any suggestions?????


    Sent from my iPhone using Tapatalk

  2. #2
    Join Date
    Apr 2017
    Location
    Ormond Beach, FL
    Posts
    9
    Post Thanks / Like
    Did you check the battery in your remote? If it’s low it may not start unless it’s held close to the start button.
    2014 Charger SRT8. Mopar CAI, Diablosport tune, resonator delete, staggered OEWheels Hellcats in Hyper Black

  3. #3
    Join Date
    Aug 2015
    Posts
    307
    Post Thanks / Like
    He would get message "Key Not Detected" I believe, or a message of low battery in fob

  4. #4
    Join Date
    Jun 2013
    Location
    Green Bay Wisconsin
    Posts
    127
    Post Thanks / Like
    check your brake switch? if it doesn't detect a brake application it won't crank. As simple as seeing if your brake lights work when you hit the pedal.
    Mopar11 Charger, MMX Cam, BBK Shorty Headers, Hemifever tune, Getrag 3.91 LSD

  5. #5
    Join Date
    Sep 2018
    Location
    Springfield, MO
    Posts
    403
    Post Thanks / Like
    Can't you pop out the push start button and use the key like normal to attempt a turn key start on this generation?
    Or was that a Benz only thing

    Any codes by chance?

  6. #6
    Join Date
    Jul 2013
    Location
    Houston
    Posts
    17
    Post Thanks / Like
    My car was doing the same thing 2013 ended up being the starter. Although the starter tested good.


    Sent from my iPhone using Tapatalk

  7. #7
    Join Date
    Apr 2016
    Location
    Toledo, OH
    Posts
    53
    Post Thanks / Like
    Quote Originally Posted by kb67mopar View Post
    check your brake switch? if it doesn't detect a brake application it won't crank. As simple as seeing if your brake lights work when you hit the pedal.
    To avoid jacking anyone's thread, I'm shooting you a PM regarding your M11
    Mopar 11

    (SOLD)2012 Charger R/T Plus: Diablo I2 w/ Hemifever 93 tune, stock 2.65's, JBA shorties, catless mids, dual 12" Cherry Bombs, reso delete, catch can, 180* t-stat, Mopar CAI. Best 1/4mi: [email protected] (street tires @ 934' DA) at Milan Dragway



Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •