Results 1 to 15 of 15
  1. #1
    Join Date
    Mar 2018
    Location
    Fairview Heights, Il
    Posts
    8
    Post Thanks / Like

    LX Need some NAG1 clarification

    Hey fello Dodge owners I drive a 07 Charger srt8

    i need some clarification on the nag1, I’ve been having some trans problems for a while now and recently (about a week ago) the torque converter lock up has stop working. Still driving the car now but babying her I plan on just doing a complete rebuild

    I’ve looked into a transtar 78006D rebuild kit and torque converter

    my problem is the valve body, what I need clarification on is are the valve bodies on all the nag1 transmissions the same?? I know the DX has the ability to paddle shift and my LX does not but surly that doesnt mean the valve bodies are different or the solenoids are different?



  2. #2
    Join Date
    Sep 2018
    Location
    Springfield, MO
    Posts
    310
    Post Thanks / Like
    Supposedly the "srt8 nag1" has tougher clutch bands or something but I'm not 100% in that...the VB and solenoids are the same unless you get the Mercedes blue tops for these which just make it feel firmer during shifting, nothing really for performance. Do you get any codes for this issue your having? Limp mode? Or is it just slipping during shifts some or all the time?

  3. #3
    Join Date
    Jul 2019
    Posts
    119
    Post Thanks / Like
    Quote Originally Posted by Dsbiker01 View Post
    Hey fello Dodge owners I drive a 07 Charger srt8

    i need some clarification on the nag1, I’ve been having some trans problems for a while now and recently (about a week ago) the torque converter lock up has stop working. Still driving the car now but babying her I plan on just doing a complete rebuild

    I’ve looked into a transtar 78006D rebuild kit and torque converter

    my problem is the valve body, what I need clarification on is are the valve bodies on all the nag1 transmissions the same?? I know the DX has the ability to paddle shift and my LX does not but surly that doesnt mean the valve bodies are different or the solenoids are different?
    You need a rebuild kit specifically for a Mercedes NAG1/722.6/W5A580 That is in a Dodge vehicle. And that Transtar kit isn't the greatest.
    I WOULD NOT swap the valve body. The Paddle shift ability is built into the vehicle, not the transmission.

  4. #4
    Join Date
    Mar 2018
    Location
    Fairview Heights, Il
    Posts
    8
    Post Thanks / Like
    I am throwing a code it’s the P0741 torque converter performance stuck off, and it’s thrown another too for incorrect gear ratio.

    since the P0741 came on the the surging has stopped at highway speeds( since its not locking anymore) only mods to her now are CAI, cat back, Diablo tune T2 Trinity, Mopar performance TCU

  5. #5
    Join Date
    Mar 2018
    Location
    Fairview Heights, Il
    Posts
    8
    Post Thanks / Like
    Looking for a good site for a rebuild kit then, any idea? just Oem style, I’m saving for gearstar just need to keep her running

  6. #6
    Join Date
    Jan 2016
    Posts
    1,171
    Post Thanks / Like
    Are you doing the rebuild yourself? There are alot of special tools needed.

  7. #7
    Join Date
    Jul 2019
    Posts
    119
    Post Thanks / Like
    I'd drop the pan and look for debris in the pan, and break open the filter and look inside it. If it doesn't have a bunch of garbage in it you don't need a rebuild. It could be the conductor plate.

    This isn't a bad kit here. 722.6 Rebuild Kit NAG1 W5A580 Mercedes-Benz Automatic Transmission Master Overhaul Banner Dodge Jeep: Oregon Performance Transmission

    I would tear it down before ordering parts. Don't order what you don't need. These transmissions hold up very well, you're probably not dealing with a meltdown here.

  8. #8
    Join Date
    Sep 2018
    Location
    Springfield, MO
    Posts
    310
    Post Thanks / Like
    Also are you sure you didn't just get water in it? The nag1 hates water, even as little as like 0.5% total fluid volume

  9. #9
    Join Date
    Mar 2014
    Location
    FL
    Posts
    151
    Post Thanks / Like
    Something worth trying before going with a full rebuild is to try changing the conductor plate. It's a common failure and it controls the whole transmission.
    I had a complete failure and ended up changing it and it's fixed everything so far.

    I documented it here. It's only a few hours of time and about $100-$120 in parts and fluid. and well worth a try.

    How I saved the transmission in my SRT8 300's! - YouTube
    My 2 Ton Beast
    2007 Black 300 SRT8
    Procharged
    Youtube Channel
    https://www.youtube.com/channel/UCo3...llSevp9qnpN6Q/

  10. #10
    Join Date
    Mar 2016
    Location
    DE
    Posts
    2,737
    Post Thanks / Like
    Which code came first?

  11. #11
    Join Date
    Mar 2018
    Location
    Fairview Heights, Il
    Posts
    8
    Post Thanks / Like
    I would agree 100%, the but is I’ve had the pan down a couple times both times the magnets were covered and the second time the filter was dropping out a metallic material and fluid was black

    the hope is that the valve body and or torque converter clutch took a dump and that’s the material I saw. The trans shop I took it to said it was having a valve body problem that was affecting the torque converter lock up.

    Car still shifts gears 1-5 ok but before the code P0741 it was surging in 4&5 making me think clutch slip and now since the code it shifts fine with no surge so I hope converter clutch bad and valve body is it


    my thinking is if I tear down and inspect then the work is done just rebuild it all and be done, maybe I’m over thinking it

  12. #12
    Join Date
    Mar 2018
    Location
    Fairview Heights, Il
    Posts
    8
    Post Thanks / Like
    P0730 first a while ago then about 2weeks ago P0741 showed up and converter hasn’t locked up since

  13. #13
    Join Date
    Jul 2006
    Location
    Corona, CA
    Posts
    2,773
    Post Thanks / Like
    Want to know more?

    Power flow..
    Chrysler NAG1 5-Speed Transmission Power Flow - YouTube

    Tear Down and inspection...
    722.6 Mercedes Transmission, Teardown Inspection - YouTube

    More info on valve body..
    722.6 valve body - YouTube

    You Tube is full of info on the Nag1 (722.6 Mercedes transmission)
    Last edited by netnathan; 01-13-2020 at 12:59 AM.
    Net is where I be......Nathan is me
    *
    2006 Charger SRT8
    Inferno Red (Just a blur to most folks) with All Factory Options / Groups, SRT8 Mats, Side moldings/rear ram's head shaved
    Billet Technology all over + valve covers and coil covers, KillerGlass Pipe, LMI FIV CAI, 180 Tstat, Magnaflow 3" exhaust
    MPR Motorsports built 6.1 based/392 NA Stroker, BBK 85mm TB, TranZformer, Kooks Long Tubes
    BCR coilovers with Hotchkis sways and Nitto 245/45/20F - 295/40/20R NT555-G2 paws


  14. #14
    Join Date
    Jan 2016
    Posts
    1,171
    Post Thanks / Like
    I would seriously consider a used trans from a place like LKQ. I got a used one from them and installed Alto clutches and seal kit from my dealer. I had to dig out a lot of special tools to rebuild all the clutch packs. The inside of the used trans was mint. I only beefed it up because it was getting a Procharger.
    Likes Ultimagic5 liked this post

  15. #15
    Join Date
    Jun 2012
    Location
    West Texas
    Posts
    313
    Post Thanks / Like
    Quote Originally Posted by Dsbiker01 View Post
    I am throwing a code it’s the P0741 torque converter performance stuck off, and it’s thrown another too for incorrect gear ratio.

    since the P0741 came on the the surging has stopped at highway speeds( since its not locking anymore) only mods to her now are CAI, cat back, Diablo tune T2 Trinity, Mopar performance TCU

    Diablo tune T2 Trinity - Check your tune and make sure that your still showing the correct gear ratio being installed.

    Mopar performance TCU - Same as above check to see if the ratio is correct for what you have installed. I replaced my T1 with a T2.... I also have the MTCM. However, the T2 did change my ratio on me atleast once. Id get the same gear ratio code. The vehicle would run if i babied it but..... If you got on it it would limp mode until you reset the vehicle.

Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •