Results 1 to 7 of 7
  1. #1
    Join Date
    Nov 2017
    Posts
    26
    Post Thanks / Like

    8.4” head unit issues

    I have a 2017 Chrysler 300 with the 8.4” touchscreen head unit. I got in my car one day and I noticed a small crack behind the screen. I guess from the Texas heat? But it’s not on the actual glass itself, it seems to be behind the screen because you can’t feel the crack when you run your finger across it. It’s making my whole head unit trip out to where I can barley listen to music or answer a phone call. Anyone have this issue or know how I can maybe have it repaired without having to spend 1500 on a new unit?
    2017 Chrysler 300s 5.7l
    Corsa performance CAI
    Airlift Performance 3P air suspension
    3" straight pipe w/ custom X pipe & universal highflow cats
    Instagram: @michaelnall22



  2. #2
    Join Date
    Mar 2017
    Location
    Bedford, Texas
    Posts
    4,907
    Post Thanks / Like
    It's the screen delaminating. They know it's an issue. Talk nice to the service writer at your dealership and they should replace it for free. If they don't, get in touch with Dodge Cares and they'll hook you up


    Sent from my moto z4 using Tapatalk

  3. #3
    Join Date
    Mar 2017
    Location
    Bedford, Texas
    Posts
    4,907
    Post Thanks / Like
    Quote Originally Posted by MikeNall View Post
    I have a 2017 Chrysler 300 with the 8.4” touchscreen head unit. I got in my car one day and I noticed a small crack behind the screen. I guess from the Texas heat? But it’s not on the actual glass itself, it seems to be behind the screen because you can’t feel the crack when you run your finger across it. It’s making my whole head unit trip out to where I can barley listen to music or answer a phone call. Anyone have this issue or know how I can maybe have it repaired without having to spend 1500 on a new unit?
    I didn't quote your original post so you probably didn't notice I had answered you

    Sent from my moto z4 using Tapatalk

  4. #4
    Join Date
    Nov 2017
    Posts
    26
    Post Thanks / Like
    Quote Originally Posted by punisher69 View Post
    It's the screen delaminating. They know it's an issue. Talk nice to the service writer at your dealership and they should replace it for free. If they don't, get in touch with Dodge Cares and they'll hook you up


    Sent from my moto z4 using Tapatalk
    How do I contact dodge cares?

  5. #5
    Join Date
    Oct 2020
    Posts
    1
    Post Thanks / Like
    My 2017 300 started delaminating exactly 3 weeks after the warranty ran out...( the car only has 25k miles on it) ( just my luck )
    Just wondering has anyone thought of a class-action lawsuit because of the problem?
    I must have read hundreds of writings and seen YouTube videos of the same problem.
    They should have made sure these units would last longer than 3 yrs!!
    I truly am upset about the quality of the Uconnect system at least once every couple months I have to pull the fuse because it freezes or becomes in responsive...

    Just Curious about the group's thoughts

  6. #6
    Join Date
    Aug 2007
    Location
    Maryland
    Posts
    476
    Post Thanks / Like
    Quote Originally Posted by roybean View Post
    My 2017 300 started delaminating exactly 3 weeks after the warranty ran out...( the car only has 25k miles on it) ( just my luck )
    Just wondering has anyone thought of a class-action lawsuit because of the problem?
    I must have read hundreds of writings and seen YouTube videos of the same problem.
    They should have made sure these units would last longer than 3 yrs!!
    I truly am upset about the quality of the Uconnect system at least once every couple months I have to pull the fuse because it freezes or becomes in responsive...

    Just Curious about the group's thoughts
    There have been class action lawsuits against Dodge for less so I say garner some interest, instead of a class action potentially try and get a recall warranted with the NTSB. Saves everyone lawyers fees?
    Hellcat PB > ET: 10.756, MPH: 131.370, 60': 1.583, R/T: .011
    Bone Stock Scat Pack PB > ET: 11.612, MPH: 119.52, 60': 1.634, R/T: .000 (gone but not forgotten).

  7. #7
    Join Date
    Jan 2019
    Location
    Carolina Beach, NC
    Posts
    23
    Post Thanks / Like
    Quote Originally Posted by roybean View Post
    My 2017 300 started delaminating exactly 3 weeks after the warranty ran out...( the car only has 25k miles on it) ( just my luck )
    Just wondering has anyone thought of a class-action lawsuit because of the problem?
    I must have read hundreds of writings and seen YouTube videos of the same problem.
    They should have made sure these units would last longer than 3 yrs!!
    I truly am upset about the quality of the Uconnect system at least once every couple months I have to pull the fuse because it freezes or becomes in responsive...

    Just Curious about the group's thoughts

    I had the same issue with delam just after warranty expired. I did have an extended warranty that covered it though. My issue is that prior to having the replacement done I notified the dealer service rep that my system had the Performance pages on it and I wanted to make sure that they would be on the new unit. They confirmed that it would be. I purchased the 300 used with 10K miles on it and it came with the Nav and the PP. When I got the car back I found that not only the perf. pages were no longer on it but that the navigation didn't work. I spent 2 weeks arguing with the dealer that they screwed me and they stated that the Nav and PP were never registered to me so I would have to pay up to get it reinstated. I argued that I did pay when I bought the car as that was considered in the purchase price but they didn't give a $#!t.

Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •