Results 1 to 5 of 5

Thread: No Horn

  1. #1
    Join Date
    Mar 2019
    Posts
    4
    Post Thanks / Like

    No Horn

    After we had the airbag recall done on our 14 300S the horn stopped working,it works when we lock the car w/ remote or hit the panic button,but the dealer states that it's some kind of module inside the steering column that's causing it.Ok I would think that's possible if we didn't have the same problem w/ our 05 Gr. Cherokee,they replace the airbag and the horn quits working.I'm thinking that when they replaced the air bags they cut,broke,shorted out that module or forgot to hook up a wire or something else. The dealer states they're not responsible for this module going bad,but on 2 different vehicles,after performing the same work the horn modules go bad?Any ideas out there or did any one else have this happen? Help!!!



  2. #2
    Join Date
    Sep 2018
    Location
    Springfield, MO
    Posts
    316
    Post Thanks / Like
    I would wager that the same guy did both cars, and didn't hook up the wire in the back before clicking the airbag back in.

    If I recall correctly, it's not that difficult to take the airbag off of the steering wheel after disconnecting the battery for 2 minutes and check. You would notice right away because the little connectors are immediately behind the airbag and will stare you in the face if it's not connected

  3. #3
    Join Date
    Mar 2019
    Posts
    4
    Post Thanks / Like
    Thanks.I'll take a look at that.

  4. #4
    Join Date
    May 2018
    Posts
    17
    Post Thanks / Like
    Quote Originally Posted by zzracer View Post
    After we had the airbag recall done on our 14 300S the horn stopped working,it works when we lock the car w/ remote or hit the panic button,but the dealer states that it's some kind of module inside the steering column that's causing it.Ok I would think that's possible if we didn't have the same problem w/ our 05 Gr. Cherokee,they replace the airbag and the horn quits working.I'm thinking that when they replaced the air bags they cut,broke,shorted out that module or forgot to hook up a wire or something else. The dealer states they're not responsible for this module going bad,but on 2 different vehicles,after performing the same work the horn modules go bad?Any ideas out there or did any one else have this happen? Help!!!
    Hi zzracer, if you end up back at your dealership, we would be happy to get a case escalated for you. We can work with the dealership to get the concerns addressed. Feel free to send us a private message if you'd like to discuss further.

    Kaitlin
    Chrysler Cares

  5. #5
    Join Date
    Mar 2019
    Posts
    4
    Post Thanks / Like
    Hi Kaitlin,thanks for responding.How do I make contact with you?

Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •