Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Join Date
    Feb 2011
    Location
    Chicago illinois
    Posts
    138
    Post Thanks / Like

    Cool Bad lifter 5.7 hemi any help appreciated!!!!!!!

    ok I have a bad Lifter in my 2005 Dodge Magnum 5.7 RWD

    I've already experienced "the infamous hemi tick" and I know it's not that
    So have narrowed itdown to a bad lifter so I am going to have to remove the heads. While I am in there I might as well upgrade the easy things. Im thinking:


    1.Replace all lifters
    2.replace all pushrods (6.1 on exhaust side to eliminate any chance of "the hemi tick")
    3.swap out stock springs for all exhaust 6.1 stock ones

    The question is should I replace the stock 5.7 cam with a stock 6.1 cam(is it worth it?)?I can get one for pretty cheap and have been looking at the sidewhinder but cant afford yet. I have 24" rims on my car and love how it performs and not really intrested in an all out street machine I dont have any mods on the car except a Fram boost CAI.


    What do you guys think I should do? Budget is limited($500-$700) but want to get the most out of it and fix the hemi tick!!!!!



  2. #2
    Join Date
    Feb 2008
    Location
    Eastern Shore of Maryland
    Posts
    1,928
    Post Thanks / Like
    Replace the lifters with the Eagle motor (09 and up 5.7). They are MDS lifters. Not sure if you should use 6.1 push rods, but I think so. Upgrade the springs with the 6.1 exhaust valve springs like you said. I have a few 6.1 cams lying around if you want one just pay to ship. You will want to replace the cam timing set, (chain-tensioner-retaining plate) use a 6.1 set. Maybe find a set of 6.1 headers and mids since you are pulling the heads. Make sure you think about keeping the EGR so you can mod the 6.1 header for the EGR or not! If you are doing the labor you should be able to stay within your budget. The lifters are the most expensive item. GL
    ARI 440 rebuilt by Charlie's Machine, Apache heads, 6.1 Intake, 87mm TB Ported by MM, TTi 1-7/8" Long Tubes and 3" Mid pipes, Dyno-Max Ultra-Flow 3" Exhaust, LMI 4" CAI, Predator, BC Racing Suspension, Magnum front w/69 Cuda Grill inserts, Trufiber SRT8 hood, Zeitronix Wideband, Hotchkis Sway Bars, SPC Front/Rear Camber Kits, 3.06 GETRAG, Builder Bill Billet Stator 3200 TC, Flex-Plate & Stage 2 Valve Body, TZ Trans Kit, Brembo brake set and Tuned by Brent @ DTP Racing.


  3. #3
    Join Date
    Dec 2004
    Location
    maine usa
    Posts
    12,743
    Post Thanks / Like
    Just out of curiosity, what are the symptoms? I've got original lifters with 225,000 miles on them, have run 6.1 springs and pushrods and the sidewinder since 140,000 miles. Always had hemi tic after cam install, but no misfire and it runs incredible. BTW, if you can find a used sidewinder for around $200, now would be a great time. I never had hemi tic until the cam, when I did a sidewinder in my Ram, no hemi tic. I guess every hemi reacts differently.
    Last edited by formerice; 08-01-2011 at 10:16 AM.
    FRI Sidewinder cam, Dynatec Headers , BorlaCatback , 93 octane dyno tune, 333rwhp/350 ft lbs, Police Pack Oil Cooler, SRT 8 Struts and Nivo's ,Hotchkis sway bars,B Woody end links, 295,000 miles, 275/40/20 Ventus ST's , 1/8th mile 7.707 sec /90.19 mph -- 05 QC4X4 Ram 205,000 mi . Never Trust a Fart

  4. #4
    Join Date
    May 2008
    Location
    Charlotte, NC
    Posts
    7,219
    Post Thanks / Like
    I have a set of 05-08 5.7 lifters in good shape if you want them.

    Also, I've run a 6.1 cam in a 5.7. You'll want an adjustable timing set. Advance the cam 4*, and you'll be good to go. With the 6.1 cam I ran with sidewinder guys. Either with 'em or beat 'em.

    Great advice on the SRT headers and mids. Also depending on your mileage, you may want to replace the oil pump as well.

    You'll need a CMR tune (Johan did mine) and personally, I'd loose the EGR.

    Look up my 6.1 cam threads for more info.

    Good luck.

    http://www.cardomain.com/ride/3247903
    The Old: Stock 5.7 Bottom End | Lead Foot | 11.861 @ 112.76 1.63 60'
    The New
    : Forged Arrington 6.1 | MMPG Top End | Paramount Drivetrain | 11.67

  5. #5
    Join Date
    Feb 2011
    Location
    Chicago illinois
    Posts
    138
    Post Thanks / Like
    Thanks guys for all the advice.

    Concussion pm sent on the lifters

    Popeye's Hemi pm sent on the cam

    Thanks guys again for all the help


    Where's a good place to get the springs and pushrods? What brand for my budget?

  6. #6
    Join Date
    Feb 2011
    Location
    Chicago illinois
    Posts
    138
    Post Thanks / Like
    Formerice the symptons are a nice tap when you startthe engine, gets a little quieter as car gets to normal operating temp. Sounds like an old caprice when you go past a wall or parked cars. Sounds like its coming from the intake or under the passenger valve cover. Used the screwdriver method and sounds like right in between the two. Im in the process of taking valve covers offthis weekend to see what I can see.

  7. #7
    Join Date
    Nov 2008
    Location
    Northwest, RI
    Posts
    5,485
    Post Thanks / Like
    My cam, srt8 springs and purshrods sound like a sewing machine. I try to pay more attention to the exhaust instead.
    2005 Magnum RT AWD 344AWHP/358AWTRQ
    FRI Sidewinder Cam, Johan Tune, Edelbrock Headers, JBA Hi-Flo Cats, Magnaflow Catback, 180* T-stat, aFe Stg II CAI, 85mm Throttle Body, SLP 25% UDP, Catch Can, Taylor Shortys, Freak351 Trans Box , Eibach Pro Kit Springs & R1's. Interior, Engine & "M" Emblems by Billet Tech, R/T Emblems, Magnum R/T Grille, Black Heads & Tails, Eyelids

  8. #8
    Join Date
    Feb 2011
    Location
    Chicago illinois
    Posts
    138
    Post Thanks / Like
    Thanks Cleary524

    What should I be looking for in the exhaust? Gaskets, bolts?

    When I first got my car before it started sounding like it does I heard a sound and swore up and down it was an exhaust gasket but it wasnt that loud so I didnt really think nothing of it. Ihave a little oil around my intake where it meets the engine. How do I know if its an exhaust leak?

  9. #9
    Join Date
    Feb 2006
    Location
    South shore of Montreal, Canada
    Posts
    1,350
    Post Thanks / Like
    Check to make sure all your spark plugs are tight. I had a noise similar as what you get on mine for a year or two before i found what it was. I was told by two mechanics (one of which was a Chrysler tech) and both were pointing at lifters. I was glad to find it was a loose plug, way cheaper and easier than to replace lifters.
    Last edited by Crazy R/T; 08-06-2011 at 01:25 PM.

    13.492@100.84
    06 Magnum R/T brillant black
    , JBA headers/mid-pipes, SRT8 cat back, Daytona rack&pignion, Police rear brakes upgrade, 3.06 SRT rear, MTCM, C&L CAI, Trinity CAI 91 tune, BT pistol grip, Kicker audio upgrade, MSRT wheels

  10. #10
    Join Date
    Dec 2004
    Location
    maine usa
    Posts
    12,743
    Post Thanks / Like
    I'm just thinking, don't remember any lifter failures, I'm sure their must have been some, but it's not common. I had the Dynatec header welds fail, sounded like bad lifters! And my car ticks like crazy after the sidewinder cam, I live with it. Old school guys hear my motor and start grinning," say what in hell have you done, it sounds hot!" For sure, check for exhaust leaks, they tend to go away when hot, sound like crap when cold.

  11. #11
    Join Date
    Feb 2011
    Location
    Chicago illinois
    Posts
    138
    Post Thanks / Like
    Ok I took the valve covers off and I think I've found the problem. The Exhaust rocker arm is barely screwed on the whole rod is damn nead out the motor. Guess the guy who rebuilt the engine looked over this. Might not be the whole solution but definately a problem. Thanks Thanks Thanks for all the advice and offers of help. I realy realy appreciate it.


    Question should I put some locktite on it to keep this from happnin again

    Wish I knew how to post pictures so I could show you

  12. #12
    Join Date
    Feb 2011
    Location
    Chicago illinois
    Posts
    138
    Post Thanks / Like

    Pictures

    Hope this works!!!!!!
    Last edited by Emailad4me; 08-06-2011 at 03:23 PM. Reason: adding pictures

  13. #13
    Join Date
    Feb 2011
    Location
    Chicago illinois
    Posts
    138
    Post Thanks / Like
    ok tighted the screw and notice the rocker arms shaft has some play in it. It is slidding on the rail sideways between the retainer and the spacer. The Assmbly tang is sliding on the Rocker Shaft hitting the spacer. Is this NORMAL?

  14. #14
    Join Date
    Feb 2011
    Location
    Chicago illinois
    Posts
    138
    Post Thanks / Like
    Everything seems to be working fine now no more tick wasnt the lifters was the rocker arm. Had a problem getting the car started but started right up onceI hit the unlock button. Thanks alot guys for all your help!!!!!

  15. #15
    Join Date
    Nov 2008
    Location
    Northwest, RI
    Posts
    5,485
    Post Thanks / Like
    Wow! That's surprising to hear the whole rocker assembly was loose. Good job troubleshooting!

Page 1 of 2 12 LastLast

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •