Results 1 to 8 of 8
  1. #1
    Join Date
    Nov 2010
    Posts
    1
    Post Thanks / Like

    Need help with TRUNK

    My 2008 Charger RT's trunk has stopped working. When I push the trunk release button(left of steering column), and on my key chain; I do not here the accuator engage. I have checked all the fuses and relays. They alll seem to be working. Does anyone know the particular fuse number, relay number, or even the wire in the harness that goes to the trunk lid? It would also be great to if someone had a schematic for that part of the car, that I could print off and reference.



    Thanks Alot
    BATMANSCHARGER



  2. #2
    Join Date
    Oct 2005
    Location
    Spring TX
    Posts
    4,237
    Post Thanks / Like
    Sometimes the fuses and relays in the front and rear PDC vibrate a bit loose. Push on every one and give a wiggle. If that doesn't work try to manually releasethe trunk then hit the release button and see if the servo makes a noise. Also you can pull the wiring clip from the trunk servo and reseat it. The servo may have gone belly up.
    2007 Road&Track Charger
    Billet Technology*AMG paddles*AFE II*Jina SSE
    Eibach&Koni*FR wheels*SRT8 hood #993*Predator
    Danko*Hurst paint & body*Wings West

  3. #3
    Join Date
    Sep 2008
    Location
    Twinsburg (NE), OHIO
    Posts
    837
    Post Thanks / Like
    i experienced the same issues earlier this year. i had wiring (3 of 5 wires) that broke apart inside the rubber sleeve that runs from trunk lid to trunk. i had to splice/solder in small sections of wiring to get enough slack.
    '07 Charger R/T Steel Blue: 300SRT rims,aFe2,Flowmaster catback,Predator,BT blue stuff,Petty strut brace

  4. #4
    Join Date
    Mar 2010
    Location
    Pueblo, Colorado
    Posts
    414
    Post Thanks / Like
    Quote Originally Posted by RichEnvE_RT View Post
    i experienced the same issues earlier this year. i had wiring (3 of 5 wires) that broke apart inside the rubber sleeve that runs from trunk lid to trunk. i had to splice/solder in small sections of wiring to get enough slack.
    X2 especially if you use your trunk alot. The flexible wires are NOT that flexible after awhile. You will need to pull the rubber boot back and visually check the wire harness that supllies the power to the trunk release.
    06 Go-Mango #1343 SLP LM 2, Predator Diablosport, 180 T-stat, CNC Shaker intake.....for now...

  5. #5
    Join Date
    Feb 2008
    Location
    Oshawa Ontario
    Posts
    6,069
    Post Thanks / Like
    Does using the key manually work ?

    If not pop it from the release inside the trunk (drop the seat and crawl in)

    Then there is a clip on the lock set that is likely broken. removing the plastic trim should make it rather obvious where/if the clip is missing.

    Had that as an issue last fall in a local members Charger.
    2006 Lil Red Wagon SXT
    Modlist : AFE Stage II, JBA Headers, Corsa Catback, 20" Vipers, Cross Drilled Rotors, Diablo Bob@SVS Tuned, Pioneer DEH-5000UB, 12" Enclosers, Halos, Low/Fog HIDs, Cuda Grille, TruFiber Chally Hood.

    at the Track

    My Garage


    Mentoria Computer Consulting

  6. #6
    Join Date
    Apr 2005
    Location
    greasy cardboard box
    Posts
    21,945
    Post Thanks / Like
    have repaired a few with broken wires in decklid jumper harness.

    Izzy pics

    Quote Originally Posted by Canadianknight
    I got it all straightened out with them guys. All good... feel bad for calling 'em a stealership now.


  7. #7
    Join Date
    Sep 2008
    Location
    Windsor, Ontario
    Posts
    111
    Post Thanks / Like
    four out of six of my wires were broke, re-attached with heat shrink clips and all is good now. this site is the best for info!!

  8. #8
    Join Date
    Jul 2010
    Posts
    48
    Post Thanks / Like
    I have a 2006 Charger R/T and hardly ever used the trunk...the mechanism went bad but could still open it manually...I tried to get Dodge to ante-up some of the repair cost but was denied...though to their credit, they have helped on various suspension issues...around $200 (if I remember correctly) for the labor and new mechanism...went on the net and found others had similar issues even without using the trunk that often...still, the best car I have ever owned...

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •