Results 1 to 6 of 6
  1. #1
    gonzo's Avatar
    gonzo is offline you know what they say about magnums....
    Join Date
    Sep 2009
    Location
    new westminster b.c.
    Posts
    390
    Post Thanks / Like

    Electric Throttle Control...is it covered under warranty?

    So my magnum seems to be broken. The light for the Electric Throttle Control is on....and flashing(which, according to my manual is a bad thing....No s**t sherlock). I'm wondering if this sort of thing is covered under warranty? or if it's gonna be out of my pocket?

    Anyone else have this problem before? It's not a good one to have. You pretty much have a non-existant gas pedal. Speeding......Not any more!!!! Can barely get upto speed now. Thanks one and all.
    '06 Magnum AWD. CAI, 22" KMC Slide wheels (black), Grill Master 5 piece black grill, Eibach Pro lowering kit (1.5" drop), JVC in-dash DVD, Art of Noise Audio Dual sub enclosures. 2 10" JL subs, JL G1700 Mono Block, LSD "Lambo" door hinges.



  2. #2
    Join Date
    Dec 2008
    Posts
    442
    Post Thanks / Like
    If you still have warranty it should be covered.

  3. #3
    gonzo's Avatar
    gonzo is offline you know what they say about magnums....
    Join Date
    Sep 2009
    Location
    new westminster b.c.
    Posts
    390
    Post Thanks / Like
    Quote Originally Posted by In HEM I Trust View Post
    If you still have warranty it should be covered.

    I have tons of warranty.

  4. #4
    Join Date
    Aug 2006
    Location
    In A Bunker......
    Posts
    5,327
    Post Thanks / Like
    Make sure you check up on the warranty......I had extended warranty and all it covered was powertrain..........Electrical parts have only a 1 year Warranty IIRC...............Check the plugs for the throttle body.......they may have just worked loose.....

    But I happen to have a spare Ported and polished throttle body kicking around the shop if your throttle body is the problem....
    2007 Silver Metallic Dodge Charger SRT8............The REAPER
    HEMI Registry #1575.......PB - 13.390 @ 106.67 Mph.

    Proud Member of The WTFDTSG Club.........

  5. #5
    Join Date
    Jun 2009
    Location
    West Kelowna, BC
    Posts
    879
    Post Thanks / Like
    Quote Originally Posted by SKULLBOY View Post
    Make sure you check up on the warranty......I had extended warranty and all it covered was powertrain..........Electrical parts have only a 1 year Warranty IIRC
    I got three years, 100 000 kms for everything when I bought mine, so hopefully yours is the same. Good luck man!
    20" Dip wheels, Mopar '10 Dual Exhaust, aFe Stage 2 CAI, Eibach Pro-kit, Alpine Type E 12.


  6. #6
    gonzo's Avatar
    gonzo is offline you know what they say about magnums....
    Join Date
    Sep 2009
    Location
    new westminster b.c.
    Posts
    390
    Post Thanks / Like
    Quote Originally Posted by SKULLBOY View Post
    Make sure you check up on the warranty......I had extended warranty and all it covered was powertrain..........Electrical parts have only a 1 year Warranty IIRC...............Check the plugs for the throttle body.......they may have just worked loose.....

    But I happen to have a spare Ported and polished throttle body kicking around the shop if your throttle body is the problem....
    I may change it even if it's not the problem. Where would I find the plugs for the throttle body? I'm thinkin that might be the case. This has happened twice now. Today and about a month ago. I can't help but think that if this was a serious situation it would be a constant problem.....I hope. Hopefully things are just lose.

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •