Page 1 of 2 12 LastLast
Results 1 to 15 of 29
  1. #1
    Join Date
    Aug 2008
    Location
    North Fla
    Posts
    897
    Post Thanks / Like

    EGR Delete Problems?

    Has anyone on the forum had any problems when they disabled the EGR with the predator
    and put on the BT kit on and still get a check engine light?I have been warned by my dealer
    that this has happened on a FEW cars!Just trying to get some feedback before i go through
    the hassle of taking that EGR motor off!Would hate to have to put it back on!!!!



  2. #2
    Join Date
    Jul 2008
    Location
    MD
    Posts
    303
    Post Thanks / Like
    I have had mine deleted for 9 months with no CEL and went thur emissions

    Silver Bullet
    5.7 Hemi Registry #949
    Baltimore Mopar Motor Club #008

  3. #3
    Join Date
    Oct 2007
    Location
    Vegas
    Posts
    5,879
    Post Thanks / Like
    humm well my block off plate should be here any day so I will let you know. I have it disabled now via predator but I have no issues.
    Last edited by scoot13; 07-15-2009 at 10:36 AM.

  4. #4
    Join Date
    Jun 2008
    Location
    Lake Grove, NY
    Posts
    3,692
    Post Thanks / Like
    same, no probs after the BT kit & delete via Predator.

    http://www.lxforums.com/board/signaturepics/sigpic23029_3.gif
    MY HEMI REGISTRY PAGE
    Quote Originally Posted by MattRobertson View Post
    ... Do it for fun and enjoy the improved performance, but don't think you made a transaction that makes any financial sense. Use the economy numbers to torpedo the tree hugger who wants to get snooty with you, but know in your heart you did it so you could go faster.

  5. #5
    Join Date
    Aug 2008
    Location
    North Fla
    Posts
    897
    Post Thanks / Like
    No i havent done it yet.My dealer warned me about this problem and wanted to know if this has happened to any forum members and if so what they did about it.Those bolts on the motor are a pain to get to.
    I have a stubby 10 mm ratchet wrench to use.

  6. #6
    Join Date
    Oct 2007
    Location
    Vegas
    Posts
    5,879
    Post Thanks / Like
    Anyone that has done the blockoff plate...did you just wrap up the plug end and hide it away??

  7. #7
    Join Date
    Sep 2006
    Location
    Ft Laud.....
    Posts
    27,450
    Post Thanks / Like
    Quote Originally Posted by scoot13 View Post
    Anyone that has done the blockoff plate...did you just wrap up the plug end and hide it away??
    Correct just tape it up,BTW Your dealer is full of $hit.

  8. #8
    Join Date
    Oct 2007
    Location
    Vegas
    Posts
    5,879
    Post Thanks / Like
    [QUOTE=BTW Your dealer is full of $hit.[/QUOTE]


    I think this might be my new sig....

    and thanks, cant wait to get em!

  9. #9
    Join Date
    Aug 2008
    Location
    North Fla
    Posts
    897
    Post Thanks / Like
    Hey Scott, going to give you a call.

  10. #10
    Join Date
    Sep 2006
    Location
    Ft Laud.....
    Posts
    27,450
    Post Thanks / Like
    Quote Originally Posted by wildwilers View Post
    Has anyone on the forum had any problems when they disabled the EGR with the predator
    and put on the BT kit on and still get a check engine light?I have been warned by my dealer
    that this has happened on a FEW cars!Just trying to get some feedback before i go through
    the hassle of taking that EGR motor off!Would hate to have to put it back on!!!!
    0 issues if its installed correctly..

  11. #11
    Join Date
    Sep 2006
    Location
    Ft Laud.....
    Posts
    27,450
    Post Thanks / Like
    Quote Originally Posted by scoot13 View Post
    I think this might be my new sig....

    and thanks, cant wait to get em!
    lol..

  12. #12
    Join Date
    Sep 2005
    Location
    Kitchener, Ont
    Posts
    10,613
    Post Thanks / Like
    Other than a bitch to remove the EGR bolts.... Zero probs.

    Stock catback, and stock drivetrain
    Typing from a tablet, excuse typos.


  13. #13
    Join Date
    Aug 2008
    Location
    North Fla
    Posts
    897
    Post Thanks / Like
    I have been warned about those screws and picked up a stubby ratchet just for this job.
    Got one at sears.

  14. #14
    Join Date
    Jan 2006
    Location
    Argyle, Tx
    Posts
    15,809
    Post Thanks / Like
    had mine deleted for 3 months with no CEL and passed emissions
    Powered & Sponsored by HHP Racing - Your #1 Source for LX Parts & Service


    400RWHP THANKS TO HHP STAGE 3 SETUP!


  15. #15
    Join Date
    Jul 2008
    Location
    MD
    Posts
    303
    Post Thanks / Like
    My block off plate is hard to see with my catch can


Page 1 of 2 12 LastLast

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •