Results 1 to 6 of 6
  1. #1
    Join Date
    Nov 2004
    Location
    SoCal
    Posts
    3,620
    Post Thanks / Like

    P3497 - MDS Rationality Bank 2

    Got this code on an 8 hour drive this weekend, about 4 hours into it, lots of highway driving, few stops for pics, gas, food, etc, we were on a road trip to our daughters.

    Code is monitored during the transition from 8 to 4 cyl mode.

    Set condition is O2 sensor readings on Bank 2 indicate a lean condition while in 4 cyl mode.

    Probable causes are:
    1. Insufficient oil pressure acting on the lifter locking pins
    2. Oil passages restricted
    3. Lifter
    4. MDS solenoid

    I need an oil change, 3500 miles on the oil and the last oil change was with dinosour oil, not synthetic. I have used both oils, but mostly non-synthetic, the synthetic does not change our gas mileage so we use reg oil normally. We have 50K on the car. Car runs well. We do have an intermittent high pitch noise at wide open throttle just at the 1/2 shift point that sounds like a belt, I doubt if this has anything to do with the P3497.

    Anybody else have this? Did a search of the forum and all I got was that Noid had this but he has a cam and lifters that do not enable MDS. Our car is stock as far as the engine goes. Running SC 91 octane tune.
    2005 Inferno Red Magnum RT
    Group I and II, sunroof, tow package, nav, sirius, Uconnect, auto headlights, 20" American Racing Torq-Thrust M Wheels, 245/45/R20 Kuhmo Ecsta ASX tires, KW V2 coilover suspension, Hotchkis sway bars, Zoomers Cat Back Exhaust, Aria CAI. LED smoked tail lights. Shaved rear hatch. Pinstriping by 2-Stix. Custom painted palm tree headlights w\halos & painted fog lamps w\halos by AAC.
    Custom Billet Tech "palm tree" pieces
    And lots of little visual mods that make it ours!



  2. #2
    Join Date
    Nov 2004
    Location
    SoCal
    Posts
    3,620
    Post Thanks / Like
    Bump

  3. #3
    Join Date
    Jun 2005
    Location
    FTW TX
    Posts
    4,328
    Post Thanks / Like
    Wish I could help, 59,000+ on my 05 Mag RT 5.7 and have used dino oil every 3000 5w-20 from day one ... been running SC 91 octane tune for years ... maybe you've got a failing MDS lifter? Or somebody gave you non-5w-20 oil at an oil change? Had that happen to me once, didn't throw a code but my MPG tanked by 3mpg when 10w-30 was put in by mistake, by the dealer no less, when the car first came out ... I went frigging ballistic, needless to say that mistake wasn't made again ...no long term damage ... MDS has worked OK ever since ...

    Based on your maintenance I'd say you have a bad lifter or MDS Solenoid .... Dealer can find it right away with the StarScan tool. Not a major repair ... should be covered by the 7-70 warranty ...
    All my posts are made from 100% recycled electrons!

  4. #4
    Join Date
    Nov 2004
    Location
    SoCal
    Posts
    3,620
    Post Thanks / Like
    Quote Originally Posted by cadzilla74 View Post

    Based on your maintenance I'd say you have a bad lifter or MDS Solenoid .... Dealer can find it right away with the StarScan tool. Not a major repair ... should be covered by the 7-70 warranty ...
    Taking the car to the dealer requires setting the car back to stock and then having the trouble code return. Going back to stock erases all codes. Since the code was set and cleared it has not set again and the mds is working normally. I do all my own oil changes, so it never got anything but 5/20. I know someone with a starscan and if the code returns we'll check into it. Also know a dodge tech at South Bay Dodge, so I'll be covered. May not happen until another road trip. It does not appear to be a high failure item, 68 reviews and your kind response. We'll just ride it out for now plus do an oil change this weekend. Thanks for the reply.

  5. #5
    Join Date
    Apr 2005
    Location
    greasy cardboard box
    Posts
    21,943
    Post Thanks / Like
    Quote Originally Posted by cadzilla74 View Post
    Based on your maintenance I'd say you have a bad lifter or MDS Solenoid .... Dealer can find it right away with the StarScan tool. Not a major repair ... should be covered by the 7-70 warranty ...
    that'd be my guess. although rare, there is always a possibility of failure but before tearing into the engine, i'd try an oil change first.
    Izzy pics

    Quote Originally Posted by Canadianknight
    I got it all straightened out with them guys. All good... feel bad for calling 'em a stealership now.


  6. #6
    Join Date
    Nov 2004
    Location
    SoCal
    Posts
    3,620
    Post Thanks / Like
    Quote Originally Posted by fnkychkn View Post
    that'd be my guess. although rare, there is always a possibility of failure but before tearing into the engine, i'd try an oil change first.
    Hey fnkychkn! Really glad to see your post. Yeah I'm gonna change the oil right away, just been very busy at work (good thing) and will do it tomorrow eve. Thanks for the reply!

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •