Results 1 to 11 of 11
  1. #1
    Join Date
    Mar 2005
    Location
    Los Angeles, Ca
    Posts
    895
    Post Thanks / Like

    Where is the crankshaft position sensor?

    My 05 RT was missing, stalling, and hard to start. CEL and BAS/ESP light came on. Got code P0335, crankshaft position sensor. Dealer has the sensor but I can't find it on the engine.

    Help



  2. #2
    Join Date
    Apr 2005
    Location
    Center of the LX Universe
    Posts
    7,994
    Post Thanks / Like
    Passenger side. Goes into the engine block.

    Assuming you have a RWD..... that means you've got to move the starter out of the way. The crank position sensor is behind it.
    FRI Econo Heads & FRI Sidewinder: Installed @ BFNY by Hemi31 with special guest Fnkychkn, JBA Shorties, JBA/HHP hi-flow catted mids, stock SRT8 cat-back, C&L CAI.
    HUGE thanks to Hemiwagn and HalfFast Performance for making it all possible.
    12.645@108.18

  3. #3
    Join Date
    Oct 2006
    Location
    Phoenix
    Posts
    14,730
    Post Thanks / Like
    oops! wrong one, Jr.
    Last edited by Junior; 10-17-2008 at 04:44 PM.

    - Click above for my HEMI Registry page -

  4. #4
    Join Date
    Apr 2005
    Location
    Center of the LX Universe
    Posts
    7,994
    Post Thanks / Like
    Quote Originally Posted by Junior View Post
    I believe it's right behind the Thermostat housing, where the coolant hose mounts to the block.

    Just to the aft from there, I think you'll see it.
    That's the Cam position sensor Junior......

    the op's looking for the crank position sensor.

    It'll be found exactly where I posted earlier. Passenger side of the block, just head of the tranny, behind the starter.

  5. #5
    Join Date
    Oct 2007
    Location
    Welland ON
    Posts
    8,975
    Post Thanks / Like
    cam sensor is on the pass side of the block, near the pan line. not sure if you have to remove the starter, guess it depends on how limber you are.
    http://www.lxforums.com/board/signaturepics/sigpic18566_2.gif


  6. #6
    Join Date
    Oct 2006
    Location
    Phoenix
    Posts
    14,730
    Post Thanks / Like
    Quote Originally Posted by Token View Post
    That's the Cam position sensor Junior......

    the op's looking for the crank position sensor.

    Doops! Thanks for the correction. I weren't paying attention.

  7. #7
    Join Date
    Apr 2005
    Location
    Center of the LX Universe
    Posts
    7,994
    Post Thanks / Like
    Quote Originally Posted by Junior View Post
    Doops! Thanks for the correction. I weren't paying attention.
    welcome to my world...... oh look.... A bunny!

  8. #8
    Join Date
    Mar 2005
    Location
    Los Angeles, Ca
    Posts
    895
    Post Thanks / Like
    Thanks Token, Junior, and Fargo59.

    Now if I had just stayed by the computer for a few minutes I might have got it replaced today. But no, I had to take a nap that lasted too long and now I have to get my girl friend to ferry the dogs to the vet for boarding since I'm going to Hawaii tomorrow for a week.

    Have a good weekend, I know I will.

  9. #9
    Join Date
    Mar 2005
    Location
    Los Angeles, Ca
    Posts
    895
    Post Thanks / Like
    Just to follow up, it was the crankshaft sensor. Pretty simple repair unless you get an idiot parts man like I did who ordered a camshaft sensor for me when they had the crankshaft sensor in stock and I had to go to the dealer three times, and wait four days to finally get the right sensor.

    Now to put on the hood struts I had to get for the originals that failed and then look into why my Bluetooth connection has now stopped working.

  10. #10
    Join Date
    Feb 2008
    Location
    Eastern Shore of Maryland
    Posts
    1,873
    Post Thanks / Like
    If it's the cam position sensor read this thread http://www.lxforums.com/board/showthread.php?t=133957 and if it's the crank position sensor read the same thread and he said its behind the starter.
    6.4 Apache Heads, 6.1 SB, SRT-MAxx Cam, 6.1 Intake, 87mm TB Ported by MM, TTi Long Tubes and Mid pipes, Dyno-Max Ultra-Flow 3" Exhaust, LMI 4" CAI, Predator, BC Racing Suspension, Magnum front w/69 Cuda Grill inserts, Trufiber SRT8 hood, SLP 25% Under Drive Pulley, Zeitronix Wideband, Hotchkis Sway Bars, SPC Front/Rear Camber Kits, 3.06 GETRAG, Builder Bill Billet Stator 3200 TC, Flex-Plate & Valve Body, MTCM, Brembo brake set and Dyno Tuned by AJ Hemituner.


  11. #11
    Join Date
    Sep 2005
    Location
    North Texas
    Posts
    5,011
    Post Thanks / Like
    Put the bunny back in the box.

    Quote Originally Posted by Token View Post
    welcome to my world...... oh look.... A bunny!
    2012 Dodge Charger

    PB 1/8 run: 7.92 @ 86.92 * 1.76 60' on street tires with DA at 1786 - All Stock

    Current mods:

    Custom tune by Lxmodguy, Stage II VB, Corsa Extreme Exhaust and LMI true CAI



Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •