Results 1 to 9 of 9
  1. #1
    Join Date
    Mar 2017
    Posts
    38
    Post Thanks / Like

    Burnt oil smell... kind find it

    2013 300c 5.7
    Every now and then, I get a whiff off burned fluid... like oil on a manifold kind of smell. it happens intermittently and isn't always repeatable. I've had the car on a lift twice and can't find any evidence of a leak.
    Are there common leak points I should check? What about that trans leak from the 1st gen lx's... does that effect us too?
    driving me crazy.

    Sent from my SM-G930V using Tapatalk



  2. #2
    Join Date
    Nov 2010
    Posts
    60
    Post Thanks / Like
    Valve cover? Just guessing.

  3. #3
    Join Date
    Mar 2017
    Posts
    38
    Post Thanks / Like
    Quote Originally Posted by guyd_15 View Post
    Valve cover? Just guessing.
    I've been all over this thing top to bottom. not a single noticeable leak or weep anywhere on the trans or engine. driving me nuts

    Sent from my SM-G930V using Tapatalk

  4. #4
    Join Date
    Feb 2012
    Location
    Orland Park IL
    Posts
    1,699
    Post Thanks / Like
    I too would guess valve cover. I've had a bad gasket that would only leak when I got the rpms up, and would drip on the headers and smoke. it can be hard to see. if you haven't already use an inspection mirror on the passenger side valve cover, up by the firewall.

    2007 BB Charger SRT8
    Airaid CAI, 180 Tstat, BT Catch Can, D1S HID headlight conversion, red led interior swap, Magnaflow cat back exhaust, MTCM, 3.73 getrag, six speed motor mounts, Lakewood 70/30 front shocks w/ V6 springs and 50/50s in back, SRT Max Plus, Paramount 55series Nag1 and torque converter, CTP solid cradle bushings
    285/35 R20 Michelin Pilot Supersports all 4 wheels
    28" hoosier slicks, MH racemaster skinnies.
    Tuned by Tim @ MPH. 403 RWHP, 402 TQ.
    12.133@111.42, 1.762 60' 620 DA

  5. #5
    Join Date
    Mar 2011
    Posts
    177
    Post Thanks / Like
    This will sound weird, but I was smelling that same smell until I had the alternator recall done. I haven't sensed that smell since.
    2013 300S AWD 5.7L V8 HEMI
    1987 Shelby Lancer #63 2.2L Intercooled Turbo, MOPAR Stage II

  6. #6
    Join Date
    Mar 2017
    Posts
    38
    Post Thanks / Like
    Quote Originally Posted by neonsox View Post
    This will sound weird, but I was smelling that same smell until I had the alternator recall done. I haven't sensed that smell since.
    ok so, now that you mention it, the smell started two weeks ago AFTER I got the alternator recall done.... isn't that somethin....

    Sent from my SM-G930V using Tapatalk

  7. #7
    Join Date
    May 2005
    Location
    Fairport, NY One retired Magnum RT, two 300s still going.
    Posts
    1,053
    Post Thanks / Like
    Quote Originally Posted by RoamingCoastie View Post
    ok so, now that you mention it, the smell started two weeks ago AFTER I got the alternator recall done.... isn't that somethin....

    Sent from my SM-G930V using Tapatalk
    You may be leaking alternator fluid! :-)
    Likes punisher69 liked this post

  8. #8
    Join Date
    Mar 2017
    Posts
    38
    Post Thanks / Like
    Quote Originally Posted by Pushbutton View Post
    You may be leaking alternator fluid! :-)
    bahahaha

    Sent from my SM-G930V using Tapatalk

  9. #9
    Join Date
    Oct 2016
    Posts
    54
    Post Thanks / Like
    My 5.7 (2008) began to occasionally produce a hot/burnt oil smell. One day it got really bad. Looked under the car and saw (*gasp*) oil dripping off somewhere near the back of the engine. Turned out on of the MDS solenoids developed a leak. My buddy, the Snap-On dealer, crawled in with a mirror and spotted oil running out from under the intake and down the back of the block. I replaced all 4.

Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •